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Abstract

�e combination of scanning electron microscopy (SEM) with X-ray microanalysis and image

processing provides a powerful ability to image and quantify microstructural features of con-

struction materials. �is document provides guidance for collecting backsca�ered electron

images and X-ray element maps of polished sections of Portland cement clinker. It furnishes

step-by-step procedures for processing image data to produce segmentation of an image �eld

into its constituent mineral phases, and describes ways use the segmented image to measure

the abundance, surface area, and spatial distribution of phases in the image �eld. Inherent

heterogeneity of the microstructure implies that di�erent image �elds of the same material

will contain di�erent phase abundances; the document suggests ways to estimate and com-

pensate for the heterogeneity length scale through statistical analysis of multiple image �elds.

and analysis using a scanning electron microscope will be illustrated using an example from

the development of Standard Reference Materials for portland cement clinker.
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1 INTRODUCTION

1 Introduction

Microstructural analysis of cementitious materials by microscopy dates back over 100 years when

Henri Le Châtelier [13] investigated portland cement clinker using what was, at the time, a new

polarized light microscopy method. He documented the optical properties of the main phases

and identi�ed tricalcium silicate as the principal constituent of portland cement clinker. Sub-

sequent work by A.E. Tornebohm, Bates and Klein [2] (see Fig. 1), and others provided a more

detailed description of the phases and textures of clinker and also developed the techniques for

light microscopy as it applies to portland cement clinker [11]. More recent resources for clinker

microscopy include the work of Campbell [6] and of Hofmänner [9]. �antitative microscopy

methods began with Delesse [7], who recognized the relationship between the area fraction of a

mineral in a 2D section and its 3D volume fraction in the material. �e �rst quantitative proce-

dures involved sketching on paper the observed microstructure, tracing the grain outlines onto

a metal foil, and �nally cu�ing and weighing the mineral constituents from the foil traces. �ese

quantitative methods evolved by subsampling the microstructure through linear traverse and

point sampling to achieve quantitative estimates of mineral abundance. �ese la�er methodolo-

gies, although more than a century old and quite time consuming, are still used today in many

disciplines for quantitative phase analysis.

�e combination of the scanning electron microscope (SEM) with image analysis has in some

ways brought quantitative microscopy back to its roots. Traditional point count and linear tra-

verse methods may still be applied to images generated by the SEM, but the SEM can be further

exploited to produce a set of high-resolution image �elds from a single material. �ese image sets

are su�ciently uniform that feature extraction and quantitative measurement by digital image

processing are possible. In this case, the mineral constituents are digitally traced and extracted

from the bulk microstructure by a set of operations termed image processing and image analysis,
which supplant the older weighing operations with semi-automated pixel counting to determine

phase abundance. �e potential for automation in the data collection and processing promises

to provide for a much greater sampling of any microstructure and quantitative estimates of mi-

crostructural features that were not easily accomplished in the past.

�is report describes imaging and analysis procedures for portland cement clinker using SEM

with backsca�ered electron (BE), X-ray microanalysis (XR), image processing and image analy-

sis. �e procedures are used to uniquely identify and separate a microstructure image into its

constituent phases, a process known as segmentation. Segmented images can be used to make

quantitative measurements such as phase abundance and surface area fractions.

It should be stated clearly at the outset that, for several reasons, microstructure imaging and

image analysis have always had—and likely will continue to have—a partially subjective aspect.

First, microstructure is not a well-de�ned material property. It is o�en characterized by signi�-

cant chemical and spatial heterogeneity that can be measured only in a statistical sense, and the

principles of uncertainty estimates for image analysis are largely undeveloped. Second, both an

electron beam’s interaction with the specimen and the digitized nature of a microstructure image

causes a level of coarse graining in which volume is homogenized into small elements that cannot

be resolved more �nely than a single pixel. But neither chemical nor phase composition of the ac-
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2 SPECIMEN PREPARATION

tual microstructure is constrained to the pixel scale; solid solutions and �nely divided phases can

cause variations in contrast that, when averaged over the pixel volume, can make phase assign-

ments uncertain for some pixels, especially at interphase boundaries and within the interstitial

phase regions. �e fraction of such “borderline” pixels is usually small within any image, but no

single objective method is currently available for infallibly assigning their phase identity. Instead,

for these cases the user must appeal to several types of possibly inconsistent data about a pixel

or pixel grouping, such as its backsca�ered contrast, X-ray element signal, and location within

the microstructure, and arrive at and informed judgment based on experience. �erefore, phrases

used in this report, such as “accurate phase assignment,” or “incorrectly assigned pixels” should

be quali�ed in terms of the best judgment of an experienced user.

Figure 1: An early thin section micrograph (1917) of belite crystals bounded by dark gray trical-

cium aluminate domains (90×, crossed Nichols [2]).

2 Specimen Preparation
�e sample taken for analysis should be as representative of the bulk material as possible. How-

ever, aside from ASTM C183 [1], no guide or standardized procedure is available for clinker or

cements. Sample spli�ers or the cone-and-quarter method may be used to reduce large-volume

samples to representative subsamples, and down to a volume suitable for making an epoxy-

embedded specimen mount. A medium-viscosity epoxy
12

is suitable for the mount because it

1
Epotek 301, Epoxy Technology, Inc., 14 Fortune Drive, Billerica, MA 01821

2
Certain commercial entities, equipment, or materials are identi�ed in this document in order to describe an

experimental procedure or concept adequately. Such identi�cation is not intended to imply recommendation or

endorsement by the National Institute of Standards and Technology, nor is it intended to imply that the entities,

2



2 SPECIMEN PREPARATION

Figure 2: Clinker microscopists relate textural characteristics to raw mix proportioning, homog-

enization, and clinkering processes, as from Ho�männner [9].

can in�ltrate any connected pores within clinker. �e clinker is embedded in the epoxy to pre-

serve the microstructure, to support the pore and fracture network during cu�ing and polishing,

and to �ll the voids to assist in pore identi�cation

A�er curing the epoxy, the specimen is cut using a low-speed diamond saw with ethanol as

a cu�ing lubricant to expose a cross section of the material. Surface damage caused by sawing

is removed using successively �ner grades of silicon carbide paper (400, 600, 1200 grit) leaving

a planar surface devoid of cu�ing and grinding fractures. �is surface is then polished to re-

move surface scratches using diamond pastes of successively �ner particle size (6 µm, 3 µm, 1 µm,

0.25 µm). A�er the �nal polish, the specimen is cleaned and carbon coated in preparation for the

SEM. A more detailed procedure for specimen preparation may be found in Ref. [16, 18].

2.1 Carbon Coating for Imaging
A thin coating of carbon is necessary to provide an SEM specimen with a conductive coating.

�ere are circumstances in which this is unnecessary (e.g., if using a variable pressure micro-

scope), but coating will provide the conductive path to ground that will reduce the potential for

charging-related problems like beam de�ection and associated image dri�, and reduction in in-

cident electron beam accelerating voltage. Carbon evaporators made for electron microscope

specimen preparation are available for this purpose. Metal coatings are not recommended be-

materials, or equipment are necessarily the best available for the purpose.

3



2 SPECIMEN PREPARATION

cause they reduce imaging signal and contrast, and they also interfere with X-ray imaging.

2.2 Sample Storage
Clinker specimens are moisture-sensitive so storage in a desiccator when not in use is necessary.

Some hydration of the more reactive constituents (free lime) will inevitably occur, necessitating

sample examination as soon as practical a�er preparation is complete. Hydration of free lime

may also re�ect sample storage-related prehydration and may be a useful observation relevant in

understanding anomalous cement behavior. �e prehydration features may be distinguished by

their surface being level with the specimen whereas hydration a�er specimen preparation will

stand in high relief due to the substantial volume increase.

2.3 SEM Imaging
High-quality images for quantitative analysis can be obtained with the following SEM operating

conditions:

1. 12 kV accelerating voltage,

2. 2 nA to 4 nA probe current, adjusted to keep a relatively high X-ray count rate with minimal

dead time,

3. a scan rate of 5 min/frame for an image size of 1024 pixels × 768 pixels to minimize BE

noise,

4. an accumulation of about 15 frames to improve the de�nition of the X-ray images

5. A magni�cation of 300×, which provides a spatial resolution of approximately 1.0 µm/pixel,

which is typically on the order of the width of the beam’s interaction with the specimen.

�ese se�ings are a useful starting point to obtain useful images, and are judged to represent a

balance between fast collection times, a match in resolution of BE images with X-ray maps, and

instrument stability.

�e local brightness in a BE compositional image is proportional to the average atomic num-

ber, Z , of the phase in that location, and the XR image re�ects element spatial distribution over

the same �eld of view. �e backsca�er coe�cient, η, is a measure of the backsca�ered electron

fraction and, following Goldstein et al. [8], is estimated using the mass fractions and η values for

each constituent. Table 1 lists phases found in clinker and cement in descending order of their

backsca�ered coe�cient and gray intensity. Caution is necessary here because the brightness

ranking may change depending upon chemistry variability due to impurities; the exact values

are not as important as the general ranking of the phases in the table. �e identi�cation of the

individual phases also includes supplemental information such as domain shape (e.g., angular or

rounded), position within the microstructure (e.g., framework grain, matrix, dispersed phase),

and bulk chemistry as described in Table 2.

4



2 SPECIMEN PREPARATION

Table 1: Clinker phases, compositions, densities, average atomic number, and backsca�ered elec-

tron coe�cient ranked according to relative SEM BE image brightness [17].

Phase Composition Notation Density (Mg m
−3

) Z η

Ferrite Ca
2
(Al

x
Fe

1-x
)
2
O

5
C

4
AF 3.77 16.65 0.1860

Free lime CaO C 3.32 16.58 0.1882

Alite Ca
3
SiO

5
C

3
S 3.13 to 3.22 15.06 0.1716

Belite Ca
2
SiO

4
C

2
S 3.28 to 3.31 14.56 0.1662

Arcanite K
2
SO

4
KS 2.67 14.41 0.1652

Aluminate-c
a

Ca
3
Al

2
O

6
C

3
A 3.04 14.34 0.1639

Aluminate-o
b

Ca
3
Al

2
O

6
C

3
A 2.56 13.87 0.1588

Aphthitalite NaCaAl
3
O

9
NCA 2.7 13.69 0.1577

�enardite Na
2
SO

4
NS 2.66 10.77 0.1249

Periclase MgO M 3.58 10.41 0.1213

a
cubic polymorph

b
orthorhombic polymorph

�e BE contrast between alite and belite is relatively strong, but that between belite and

cubic tricalcium aluminate is generally too low to rely on contrast to distinguish them. For such

phase pairs that have similar BE coe�cients, or for phases that have BE coe�cients too low to be

resolved in the BE image, XR imaging is used to distinguish them based on their composition. For

example, periclase and some alkali sulfates o�en appear black, like the epoxy-�lled voids, because

of the brightness and contrast se�ings necessary to make the other phases distinct. Combining

the XR and BE images facilitates their discrimination much be�er than relying on either image

alone. Information redundancies also occur that should be reduced or eliminated to improve the

phase distinction. For example, the Ca and Si XR image, or a ratio of the two, may be considered

for distinguishing the calcium silicate phases. �e BE image, however, provides a much be�er

distinction between the calcium silicates and is preferred because of it is less “grainy” than the

XR image. Further details and examples of how SEM images may be combined to render these

phases distinct will be shown in a later section.

2.4 X-Ray Microanalysis and Imaging
X-Rays are produced as a result of the interaction of the electron beam with the specimen, and

they are typically displayed as a set of peaks with a continuous background (Fig. 3). �e energy-

dispersive X-ray analyzer (EDX) ranks and counts X-rays based upon their energy. �e spectrum

from alite shown in Fig. 3 has the characteristic peaks for calcium, silicon, aluminum, magnesium,

sodium, oxygen, and carbon (the conductive coating), and a background. �e concentrations of

the elements can be quanti�ed if suitable standards are available, and are typically expressed as

mass percent of the oxide.

5



3 APPLICATION TO SRM 2686A

Table 2: Textural and chemical characteristics useful for distinguishing clinker phases.

Phase Identifying Characteristics

Free Lime Bright BE, rounded crystals, sometimes clustered,

strong Ca and no Fe

Ferrite Bright BE, dendritic to prismatic matrix phase, high Ca,

medium Fe and Al

Alite Medium-high BE, euhedral to anhedral crystals, frame-

work grain, strong Ca and Si, minor Mg and Al.

Belite Medium BE, rounded crystals, framework grain, strong

Ca and Si, minor Mg, Al, and weak S. Sometimes clus-

tered.

Aluminate Medium BE, �ne to lath-like crystals, matrix phase be-

tween ferrite crystals, Ca, Al, Mg, K, Fe and sometimes

Na.

Arcanite Medium BE, crystals dispersed, typically along bound-

aries of matrix and framework grains, high K, S

Aphthitalite Low BE, crystals dispersed, typically along boundaries

of matrix and framework grains, high K, Na, S

�enardite Low BE, crystals dispersed, typically along boundaries

of matrix and framework grains, high Na, S

Periclase Low BE, equant to dendritic grains, clustered to dis-

persed

3 Application to SRM 2686a

�is section demonstrates the use of the foregoing procedures for analyzing the NIST Standard

Reference Material (SRM) clinker 2686a [15]. A representative BE image of this clinker is shown

in Fig. 4, and all subsequent images in this section will use the same image �eld for illustration

purposes. �e phase domains in this clinker have an intermediate size compared to the other

SRM clinkers. �e spatial distribution of phases is heterogeneous, and li�le free lime is detected.

Alite occurs as subhedral to anhedral crystals approximately 30 µm in size. Belite occurs in large

clusters with an approximate crystal size of 20 µm. �e matrix is di�erentiated with a medium-

to �ne-grained lath-like ferrite, and �ne-grained aluminate �lling the inter-lath voids. Equant

periclase crystals up to 15 µm are common throughout the microstructure and the alkali sulfate

phases aphthitalite and arcanite are distributed throughout the microstructure. According to the

Hofmänner diagnostic chart in Fig. 2, the belite clustering represents heterogeneity or over-sized

silica grains in the raw mix. �e �ne-grained matrix indicates rapid cooling from 1300
◦
C, and

the slightly elevated belite content may re�ect a slightly low CaO content.

An annotated BE image of this clinker is shown in Fig. 4, illustrating the distinct contrasts be-

6



3 APPLICATION TO SRM 2686A

Figure 3: Energy-dispersive X-ray microanalysis shows spectra from the primary clinker phases

exhibit characteristic spectra on a continuous background and standard-based quantitative anal-

ysis of chemical composition expressed as oxides.

tween most of the phases. Reference to Tables 1 and 2 should allow one to identify the constituent

phases. While the contrast between belite and aluminate is not distinguishable, as mentioned in

the previous section, they are still texturally distinct and can be distinguished on this basis even

within the BE image, the belite being a large-grained framework grain and the aluminate being

a �ne-grained matrix. Periclase and alkali sulfates appear dark, like the voids, although they

would be easier to detect with a brighter image se�ing. �e ancillary XR images for the major

elements will be used to identify the locations of these phases as well as isolate them in the image

processing stage.

�is image set was collected at 1200× magni�cation using a 1024 pixel × 768 pixel image,

producing a spatial resolution of 2 µm/pixel. �is is in excess of that used for routine imaging

and was done here to be�er illustrate the phases. �e set of XR images associated with this

backsca�ered electron image is shown in Fig. 5. �ese images were collected simultaneously

7



3 APPLICATION TO SRM 2686A

Figure 4: SEM backsca�ered electron image of SRM 2686a, showing a medium-grained, hetero-

geneous silicate distribution and a coarse-grained matrix with phase identi�cations. Field width

is 256 µm.

so they are registered, with the same pixels on each image representing the same region. �e

brightness is proportional to X-ray counts, and roughly proportional to element concentration.

While the �gure is displayed as a gray-scale image, pseudo-coloring can sometimes improve the

visualization of the element distribution. �e images in Fig. 5 have been modi�ed to remove

contributions from the continuous spectrum background using a simple subtraction routine that

will be described more fully in the next section.

�e energy-dispersive X-Ray signal consists of the characteristic spectrum for each element

and a continuous spectrum, o�en called the background (Fig. 3). �is background will contribute

image noise that may be signi�cant, especially for 8-bit image formats that can resolve only 256

gray levels. A 16-bit image format, with 65 536 gray levels, can o�er a be�er signal-to-noise ratio.

In other cases, low concentrations of an element are expressed as a very weak and variable signal,

given the relatively short X-ray imaging dwell time. While these low-concentration elements are

helpful for quantitative microanalysis of clinker mineral compositions, they are not as useful for

phase segmentation, and are another example of redundancy.

�e di�erences between the silicates, alite and belite, are shown in the BE image (Fig. 4). �e

di�erences in concentration of Ca and Si in the associated XR images (Fig. 5) re�ects the di�erent

Ca and Si concentrations of alite and belite.

�e aluminum and iron images in Fig. 5 highlight the interstitial (matrix) phases, aluminate

and ferrite
3
. �ese elements also exist in low concentrations in some of the other phases, and

will therefore have low counts throughout other portions of their XR images. �e iron image is

another example of an image redundancy because it highlights mainly the ferrite and, to a lesser

3
For brevity, tricalcium aluminate is routinely designated simply as “aluminate,” distinguished as cubic or or-

thorhombic where appropriate, and tetracalcium aluminoferrite is designated as “ferrite”.

8



3 APPLICATION TO SRM 2686A

Figure 5: X-ray microanalysis images of the spatial distribution of elements for the �eld of view

shown in Figure 4. �e image in the upper le� is the BE image. Field width is 256 µm.

degree, the aluminate phase. �ese phases are be�er distinguished in the BE image (Fig. 4) and,

for aluminate, the BE and the Al image, so the iron image is not used for the image processing.

�e aluminum XR image, however, is important because it can be used together with the BE

image to distinguish belite from aluminate based on the high concentration of Al the la�er phase.

Further features that stand out upon a cursory scan of Fig. 5 are periclase crystals dispersed

throughout the image (regions of high Mg), arcanite (areas with strong signals from both S and

K), and aphthitalite (regions with S, K, and Na).

For a more systematic exploration of the phase constituents and their distribution in the

clinker, the �rst step is to examine the individual and then combinations of the image set. �is is

accomplished using ImageJ [10], or a similar image viewer, and merging di�erent image combi-

nations. Two combinations can generally serve to highlight all the phases. �ese combinations

may also be used to see if a particular image improves or confounds a phase distinction, allowing

the user to decide on adding that image to the set that will be used for the image processing used

9



3 APPLICATION TO SRM 2686A

to uniquely identify the clinker phases. ImageJ can merge up to seven images while most other

codes display three, as a red, a green, and a blue color plane (RGB). Displaying the BE image, Mg,

and Al as a RGB image allows distinction of alite, belite, ferrite, aluminate, periclase, and voids.

Displaying the BE image with K and Na provides distinction of the alkali sulfates. �is process

will be discussed in more detail in a later section.

Figure 6: Reducing noise associated with the continuous spectrum background improves the de-

lineation of aphthitalite from the raw Na XR image (le�) and histogram, as shown in the processed

subtracted image (right). Field width is 256 µm.

3.1 Image Processing
�e next four sections provide detailed guidance for processing the experimentally obtained im-

ages and transforming them to a single phase segemented image suitable for quantitative stere-

ological analysis. �e Appendix provides a condensed set of instructions distilled from this dis-

cussion.

As an example applied to SRM 2686a, Fig. 6 shows the Na XR map associated with one �eld

of view. In this image, the continuous background and inherently low counts associated with

aphthitalite are problematic for segmentation decisions, because they reduce the signal-to-noise

ratio relative to that in an image with a greater element concentration. �e background count

level can be determined from the histogram (see the insets of Fig. 6), or by reading the counts

while scrolling the pointer across the background; the Na image in Fig. 6 registers about 10

counts. Once the background count level is determined, the background can be subtracted. To

do so within ImageJ, choose the Process→Math→Subtract operation. �is operation opens a pre-

view option window where the subtraction threshold value can be entered (10, in this case). �e

resulting image, shown as the right image in Fig. 6, more clearly distinguishes the aphthitalite

domains.

�e Mg XR map for the same �eld of SRM 2686a shows the spatial distribution of Mg in

the silicates, the matrix, and, in particular, periclase (Fig. 7). �e silicates and matrix phases

10



3 APPLICATION TO SRM 2686A

are more clearly distinguished using a combination of the BE image and Al XR image, so the Mg

distribution information is not needed for their segmentation. �e low concentration distribution

of Mg becomes apparent in the Mg image by expanding the brightness and contrast (Fig. 7, le�).

Just as for the Na distribution, removal of the low-concentration and background counts from

the Mg map produces a clearer delineation of the Mg distribution for periclase. In this case,

scrolling the pointer over the low-Mg phases, such as alite, in the upper image of Fig. 7 indicates

the maximum background level to be about 20 counts, so 20 can be used as the threshold value

in ImageJ’s Process→Math→Subtract operation to produce the right image in Fig. 7.

ImageJ has other operations in its Image→Noise menu for removing additional image artifacts

(e.g., speckling) that can complicate phase segmentation decisions. Examples include Despeckle
and Remove Outliers.

Figure 7: Mg XR map associated with low concentrations in the silicates and matrix phases

may confound segmentations. Subtracting low-level signal associated with background and low

concentrations of Mg presents a clearer rendering of periclase location. Field width is 256 µm.

Smoothing �lters, several of which are available in ImageJ can improve the distinction be-

tween phases, but selecting one that preserves edge detail is important to preserve the texture of

the clinker microstructure. A useful ImageJ �lter is called �resholded Blur [20], which features

an interactive, selective mean �lter and displays an image preview to assess the e�ect of the �l-

ter’s se�ings prior to commi�ing it. Used carefully, this �lter will enhance distinction between

phases by reducing noise and retaining edge de�nition. It will later be important for cleaning up

incorrectly assigned pixels a�er the segmentation is complete. Figs. 8 and 9 show examples of

the application of the �resholded Blur algorithm to the BE image and the Ca XR image, respec-

tively. �e BE image exhibits the lowest noise of the set, although there can be some variability

in gray intensity and minor scratches that may appear slightly darker than the surroundings.

�ese minor imperfections can be removed by careful selection of smoothing se�ings. In Fig. 8,

image set (A) is the original BE image, including �ne scratches; a magni�ed portion is shown at

the bo�om of the �gure. �e smoothed image (B) in Fig. 8 shows a much more uniform gray for
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3 APPLICATION TO SRM 2686A

Figure 8: �resholded blur �lter applied to the BE image removes minor scratch marks and makes

the gray levels for each phase more uniform as seen in the images and gray level histograms. Field

width is 256 µm.
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3 APPLICATION TO SRM 2686A

Figure 9: �resholded Blur algorithm applied to the Ca X-ray image improves the distinction

between phases by comparing gray level histograms from the initial (A) and �ltered (B) images,

which now shows distinct peaks for alite, belite and matrix. Field width is 256 µm.

Figure 10: Composite image with the BE as red, Mg as green, Al as blue and S as yellow illustrates

how the addition of the X-ray data improves phase identi�cation. Alite is a brighter red than

belite, the matrix phases are bluish (aluminate) and pink (ferrite), periclase is green, and alkali

sulfates are yellow. Field width is 256 µm.
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3 APPLICATION TO SRM 2686A

each phase, with the �ner scratches removed while retaining the grain boundaries, and provid-

ing an improved distinction between the silicate histogram peaks. �e smoothing se�ings that

produced Fig. 8 (B) included a kernel radius of 2 pixels, an intensity threshold of 10, a so�ness of

0, and strength of 2. �ese values were selected based on the description of their functions [10]

and the e�ects on smoothing the image without loss of phase de�nition.

3.2 Visualizing Phase Occurrence and Distribution by Color Merge
�e Color Merge operation in ImageJ is a useful tool to visualize and identify the phases and their

spatial distribution. �is operation combines, or stacks, BE and XR images while assigning unique

colors to each image. �e colors blend and, depending upon the image combination chosen,

highlight the di�erent phases. �is is best done with a subset of the XR images or with XR

images and the BE image. �e important images to combine include the BE, Mg, Al, K, Na, and

S. Other images either do not further aid in phase discrimination (e.g., Ca, Si) or have such low

concentrations that their noise confounds the phase segmentation (e.g., Ti, Mn).

�e color merge is accomplished in ImageJ using the Image→Color→Merge Channels oper-

ation. Depending on the version of ImageJ, up to seven images can be merged at once. Fig. 10

shows the merging of the BE (red), Mg (green), Al (blue), and S (yellow). Arcanite and aphthi-

talite could be distinguished from each other by adding the K and Na images to the merge. �e

aluminum XR image makes the distinction between belite and aluminate clear, even though their

contrast in the BE image is nearly the same. �e Mg image reveals the locations of periclase,

while the S image highlights the alkali sulfates. Alkali sulfate phases in Fig. 10 are evident at

grain boundaries and within fractures of the belite crystals, which are typical locations for these

phases. Simpler image combinations than those in Fig. 10, such as BE-Mg-Al and BE-Na-K, can

be useful for identifying phases, especially if the image display code can show only three color

planes.

With the visualization of the phases and their distribution as in Fig. 10, the next step in quan-

titative image analysis is to train the segmentation routine to recognize the individual phases

and then generate an indexed image in which each phase is uniquely identi�ed and coded. �is

process involves classi�cation of each pixel as the phase to which it most likely belongs, based

upon a user-created training set and multispectral image processing.

Based on the exploratory analysis using ImageJ and the color merging operations illustrated in

Fig. 10, a minimum set of images selected to discriminate each phase are included in the segmen-

tation operations. �is set typically includes BE, Al, Mg, K, Na, and S. As mentioned previously,

other element images should not be included because they do not add any new information to

the image set, and may even confound the segmentation. More details on the data collection, the

multi-spectral image processing, and analysis are given elsewhere [12, 19].

3.3 Image Processing with MultiSpec
MultiSpec, a so�ware package developed at Purdue University, is a processing system for inter-

actively analyzing multispectral image data [14]. It is used here to generate the �nal segmented
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3 APPLICATION TO SRM 2686A

image from a small subset of images described in the previous section. A condensed set of in-

structions for using ImageJ and MultiSpec can be found in the Appendix. �is section provides

a summary of the steps required to compile a data set, establish the training �elds, classify, and

generate the segmented, indexed image for �nal analysis.

MultiSpec has tools to help establish an optimal data set for analysis, but the relative simplicity

of the phase chemistry and image sizes make this a relatively straightforward task that can be

e�ciently completed with ImageJ’s Color Merge operation described earlier. �e less useful X-

ray images can optionally be included, but they should be placed as the last of the images so that

they can be easily excluded from the classi�cation if necessary.

MultiSpec identi�es and reports the image size, bit depth, and number of planes (RGB color

or single gray). In most cases, the default parameters suggested by the so�ware can be accepted.

In some cases when processing is performed, an option is available to write a text �le with the

details and a processed image �le; such cases will be noted in the following description.

Processing clinker or cement microstructure images with MultiSpec involves seven basic

steps:

1. Load the BE image

2. Link the BE image to the XR image set

3. Rectify and save the linked �les

4. Identify phases (class assignment)

5. Set up training �elds

6. Perform phase segmentation and check its quality

7. Save the MultiSpec project

Step 1: Load the BE image. Fig. 11 shows how to load the BE image as a multispectral type

using the File→Open Image menu item and selecting the multispectral option. Under the “Mul-

tispectral Display Speci�cations” section of the dialog, the defaults can all be accepted with the

exception of the “Enhancement” section; here one will usually opt to leave the image unchanged

since background noise was removed using the ImageJ Process→Math→Subtract function, but

the image can also be clipped on the low and high end, or user selected clipping based upon a

percentage of the gray level.

Step 2: Link BE and XR image sets. XR images that previously have been deemed useful in

making a segmentation must be linked to the loaded BE image using the File→Open Image menu

item, as shown in Fig. 12. Select the (already-modi�ed and optimized) XR images by clicking on

them individually, and check the box or drop-down menu for each new �le to indicate “Link to

active image window”. Deciding on a standardized image sequence is helpful to later recall the
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3 APPLICATION TO SRM 2686A

Figure 11: Loading the SEM BE image in MultiSpec interprets the image �le details with an

enhancement option to trim a percentage of the high- and low-end signal, if necessary.

exact image source in the virtual linked �les (BE, Al, Mg, K, Na, S). �ese linked images can be

named individually later if necessary. Any image in the sequence can also be excluded if it is later

determined to hinder the classi�cation of phases. As already stated, image exclusion is easier if

the potentially problematic XR images are placed at the end of the linked image sequence. Click

on the Cancel bu�on to complete the linking.

Step 3: Rectify and save linked �les. Use the Processor→Reformat→Rectify Image menu

item, shown in Fig. 13, to rectify the linked �les. Options are provided to subsample, translate,

and rotate the images, although this is rarely needed because the SEM image set should already

be suitably registered. However, if beam charging caused the BE image to be misaligned relative

to the XR image set, these options can help resolve the discrepancy. �e default values of the

other parameters can be accepted. �e Processor→Reformat→Add Channel Descriptions option

allows one to add a descriptive name for each channel, which can be useful for keeping track of

image sets that use nonstandard image sequences. Provide a �le name with a .LAN extension

and, before saving, check that the path is correct because it may not default to the original folder.

A good practice is to use the original �le name and keep everything together together in a folder

of the same name. Note: Using a .LAN extension on the �le name is important; without the .LAN

extension MultiSpec will not automatically recognize the �le as valid for any subsequent loading

in the next steps.

Step 4: Assign classes. Reload the .LAN image set using the File→Open Image menu item

(Fig. 14). If it is not highlighted as a readable �le, designate the �le type as “Multispectral Image

Files” section of the dialog window.

Once the image set is opened, a window labeled “Multispectral Display Speci�cations” will

appear (Fig. 15) where channel colors can be assigned (R G B), image enhancements such as

clipping or transformation can be made, and image sets can be subsampled by lines and rows.

�is display tool functions much like the Color Merge operation in ImageJ, but it allows only
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MultiSpecLink

Figure 12: Linking the BE image to a set of XR images from the same �eld of view is accomplished

in MultiSpec by selecting each XR image, specifying “Link selected �le(S) to active image window”

in the drop-down menu, and completed by selecting Cancel.

Figure 13: Saving the linked BE and X-ray images using the Processor→Reformat→Rectify pro-

vides a chance to subsample the set and repair any image registration issues (recti�cation).
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3 APPLICATION TO SRM 2686A

Figure 14: Selecting the linked, recti�ed multispectral image set, indicated by �le extension .LAN

will allow display of the image set and establishing training �elds.

three color planes. �e three-color limitation may seem restrictive, but it reduces the likelihood

of confusion in interpreting the displayed images.

Figure 15: �ree-color (RGB) display by channel will provide a rendering of phase distribution

for the next step of establishing the training �elds.

When assigning channel colors in the “Multispectral Display Speci�cations” window, choose

channel/color combinations that will provide a clear rendering of the phase distribution. �e most

useful for clinker is the combination of BE (Red), Mg (Green), Al (Blue), which can clearly reveal

alite, belite, aluminate, ferrite, periclase, lime, and void, as shown in the le� image of Fig. 16. To

complement such a color scheme, alkali sulfates can be readily identi�ed with the combination

of BE (Red), K or Na (Green) and S (Blue), as shown in the right image of Fig. 16. O�en the Na

image is redundant with K, but in this example there are di�erences representing two distinct

alkali sulfate phases. �is second color combination is useful because alkali sulfates are di�cult

to perceive from the BE image alone. �e BE coe�cient for arcanite is close to that of belite, and

aphthitalite’s BE coe�cient is low enough that it may be mistaken for void space without the

additional X-ray information from the Na image.

18



3 APPLICATION TO SRM 2686A

Figure 16: MultiSpec Image→Display allows three channels to be assigned to Red-Green-Blue

color planes to facilitate identi�cation of phase type and distribution. �e upper image is BE

(red), Mg (green), and Al (blue) while the lower is BE (red), K (green), and Na (blue). Field width

is 256 µm.

Figure 17: Training �elds are de�ned by boxing regions typical for each phase (class) and assign-

ing a class name. Additional training �elds are created by selecting a phase, boxing a new region,

and adding it to the class.
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Figure 18: Classi�cation is initiated by selection of a procedure, the use or exclusion of some

image channels, and writing the classi�cation results to a disk �le.

Step 5: Establish training �elds. When all the phases are identi�ed as in Fig. 16, training

�elds must be assigned to condition MultiSpec for the image segmentation step.
4

A powerful

feature of MultiSpec is its ability to establish training classes by interactively highlighting re-

gions of the image that are associated with speci�c phases. To set up the training classes, use

Processor→Statistics, and accept the defaults in the “Set Project Options” dialog window. With

the recommended image combinations to highlight the phases from the previous step, regions

for each phase (or class) can be designated as shown by the white outlined boxes in Fig. 17.

�e “New Project” window shows a Class Designation at the top, with ‘New’ as the default.

A list of classes can be initiated here by boxing in a region in the image (mouse click and drag)

across each phase individually. For each phase, the class is then added by clicking the “Add to List”

bu�on and providing a name (e.g., alite, belite). �e de�nition of class characteristics improved

as more pixels are added to the training sets. �erefore, the largest possible box ordinarily should

be selected for each phase. If the box accidently covers an unwanted area, recreate the box before

selecting “Add to List”. An option is available for selecting polygonal regions instead of boxes,

by clicking on line segments until the polygon is closed, but the box approach works quickly

and is usually su�cient for de�ning classes. If a �eld appears to be incorrectly assigned a�er

being added, it can be deleted before continuing by selecting class and then �eld in the project

window to get a list of individual �elds. Select the �eld you wish to delete and from Edit in the

top command bar, select “Cut Field” to delete.

Classes will have an associated index value that is assigned based on the order in which

the �elds were added to the list in the Project window. A given class also optionally can be

re�ned further into subclasses. For example, a generic alkali sulfate class could contain subclasses

for arcanite and apthitalite, although a generic class is rarely helpful in phase segmentation.

�e important point is to use a consistent sequence to facilitate phase identi�cation and further

quantitative analysis of the indexed image. �e following convention is highly recommended:

4
MultiSpec has a built-in automated segmentation utility, which ordinarily would eliminate the need for train-

ing classes described here. However, we have found that MultiSpec’s automated segementation utility yields less

thorough, less accurate segmentations than can be obtained by establishing training classes.
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1 = alite 2 = belite 3 = aluminate 4 = ferrite

5 = periclase 6 = arcanite 7 = aphthitalite 8 = void

�e index assignments should be recorded for later use. If phases are absent, the index values

shi� down accordingly. For example, if a clinker has no identi�able periclase, then the indices

for arcanite, apthitalite, and void would all decrease by one.

Step 6: Segment phases. Use the Processor→Classify command to begin the image segmen-

tation algorithm. Seven classi�cation procedures are available in MultiSpec, and it is relatively

easy to test them all to determine which one yields the best segmentation. �e classi�cation

window is shown in Fig. 18. In general, both the “Minimum Euclidean Distance” and the “Fisher

Linear Likelihood” algorithm work well for segmenting clinker or cement images. �e results are

saved by checking the “Disk File” radio bu�on under the “Write Classi�cation Results” section

of the window. Prior to saving, the �le path should be checked and the .GIS extension should be

retained for the image.

�e relative merit of a classi�cation should be based on how well the classi�er is able to re-

assign the training pixels to their designated class (Fig. 19) and, most importantly, on the agree-

ment between the classi�ed image (.GIS) and the operator’s interpretation of the BE image. �e

.GIS image is read into MultiSpec as a “Multispectral” type image, and the class assignments are

shown with distinct colors, as in Fig. 20. �e color of any phase can be changed by double clicking

it in the class list and se�ing its color with the color picker. If the segmentation is acceptable, this

image can be saved as a TIFF �le (File→Save Image to TIFF ). Note: �e �le must be saved in TIFF

format because that is the only format that retains the index values that are needed for the �nal

analysis steps.

Step 7: Save the project. Select the File→Save Project As menu item to which will retain all

the e�orts and results of the segmentation process. Even if a segmentation a�empt is deemed

unsuccessful, the project can be reloaded later and modi�ed to add training �elds, delete �elds,

run alternate classi�cation algorithms, or even exclude speci�c images to see if the classi�cation

can be improved.

3.4 Cleaning up the segmented image
Even a�er the image segmentation in MultiSpec, some incorrectly assigned pixels are commonly

found. Especially along grain boundaries or particle edges, contrast artifacts in the original SEM

BE image can cause pixels to be incorrectly classi�ed. �ese e�ects are ideally minimized be-

forehand by careful adjustment of brightness and contrast se�ings during acquisition of the SEM

BE image. In this example (Figs. 20 and 21), the edge e�ects created a problem for the Maximum

Likelihood classi�er based upon inspection of the segmented image. �e Fisher Linear Likelihood

classi�er generated a more accurate grouping of pixels but still had some incorrectly assigned pix-

els along the edges and within the belite grains. If not too severe, incorrectly assigned pixels may

be removed a�er segmentation by using some of the smoothing �lters in ImageJ. �reshold Blur
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Figure 19: MultiSpec classi�cation table, or accuracy matrix, shows the classi�cation set assign-

ment accuracy, incorrectly assigned pixel counts, an overall accuracy assessment by the Kappa

statistic, and the area fraction for each class [12]. Data shown here are based on one image, so no

uncertainty statement is possible. �e “Reliability Accuracy” value for each phase refers to the

percentage of training set pixels that are correctly reclassi�ed by the segmentation as the phase

to which they were originally assigned.

Figure 20: Comparing the segmented image to the original BE image (Fig. 4) indicates a success-

ful segmentation. Some incorrectly assigned pixels occur at grain boundaries and within belite,

which will be repaired in the �nal processing step. Field width is 256 µm.
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Figure 21: Original SEM BE image (le�) and the processed, segmented indexed image (right) for

comparison. Segmentation used the Fisher Linear Likelihood algorithm. Field width is 256 µm.

works well for minor edge e�ects by ignoring pixels that deviate from the mean and by allowing

one to specify the kernel radius (start with 2 or 3), threshold (1, 2, or larger because this is an in-

dexed image and the values di�er by increments of 1), so�ness (a�ects the edge blur) and strength

(number of times to apply the �lter). A�er the edge e�ects have been reduced or eliminated in

the .GIS �le, save this and a TIFF and also write the ASCII Indexed �le: File→Save As→Text Image
that will be used in the image analysis. If needed, the .GIS �le in Multispec or the *MS.TIF �le in

ImageJ can be recalled to see which index value corresponds to each phase.

�e completed segmentation with edge e�ects removed and original BE image are presented

in Fig. 21 to illustrate the �nal segmentation results. �e image is color-coded and indexed with

alite (blue, 1), belite (brown, 2), aluminate (white, 3), ferrite (red, 4), periclase (pink, 5), arcanite

(blue-green, 6), aphthitalite (yellow, 7), and porosity (black, 8).

3.5 �antitative Image Analysis
�e �nal result of phase segmentation is a 2D color image that identi�es each pixel with an

integer index associated with its assigned phase. �antitative analysis can be performed on such

an image to calculate, for example

1. the area fraction of each phase (on a total solids basis)

2. the perimeter fraction of each phase (on a total solid boundary length basis)

3. the spatial distribution of each phase, quanti�ed by correlation functions

4. the possible percolation, or connectivity, of each phase

Many, if not all, of these operations can be performed by built-in functions, such as generating

a histogram and list from the indexed image or augmenting ImageJ with Java plugins such as the

correlation function. However, most of these plugins have been developed and optimized for
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image processing in other �elds, especially biology, and are not well-documented or validated

for use with clinker or cement microstructure images. As an alternative, NIST has developed a

simple, fast computer program speci�cally for performing quantitative image analysis on clinker

or cement microstructures. �e program, called MicroChar, is available for Windows or Mac

OS X computers, performs all these calculations with minimal intervention by the user. Use of

MicroChar is described in the following section.

3.5.1 Installing MicroChar

MicroChar can be downloaded as disk image (on Mac OS X) or installer (on Windows).

Installation on Mac OS X. Double click the disk image to mount it. �is will open a window

as shown in Fig. 22. �e application can be installed by dragging its icon to the Applications

folder.

Figure 22: Installation of MicroChar on Mac OS X computers.

Installation on Windows. Double click the installer. If the user accepts the disclaimer, then

choose a folder in which to install the application folder. A�er installation, a shortcut icon will

be placed on the Desktop and in the Start Menu.

3.5.2 Using MicroChar

Launch MicroChar by double-clicking its icon. A window will open as shown in Fig. 23. Mousing

over many of the items in the window will display a tooltip. For more context-speci�c informa-

tion, click on the blue question mark icon in the toolbar and then click on the window item about

which you want more information.

To begin a session, click on the blue folder icon in the upper le� toolbar (or type Ctrl-O, to

open the indexed image resulting from phase segmentation. �e application works equally well

on indexed images either of clinker or of powdered cement embedded in epoxy, but it anlayzes

the void space and perimeter identi�cation di�erently for the two kinds of images. �erefore,

a�er �le selection, check the “Clinker image” checkbox only if the image is a clinker nodule;

otherwise leave it unchecked. Specify the image resolution in terms of the width of a single pixel

in micrometer (µm) units. �e pixel dimension should be known at the time that the SEM image
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3 APPLICATION TO SRM 2686A

Figure 23: MicroChar main window.

is acquired, and is necessary to associate a length scale with the correlation functions that will

be calculated if the corresponding checkbox is activated.

�e remaining items in the window, which are grayed out by default, are related to data

needed to create a cement data package for the Virtual Cement and Concrete Testing Laboratory.

�ese items, which can be activated only for cement images by clicking the “VCCTL Package”

checkbox, are beyond the scope of this document. Readers who are interested in using VCCTL

so�ware should consult the VCCTL so�ware documentation [21].

Calculations begin by clicking the Execute bu�on at the bo�om of the window. �e program

reads the image �le and records all the phase index numbers. When these have been collected,

the user is prompted to associate each index with a known phase, as shown in Fig. 24. A default

collection is o�ered, but each phase can be manually assigned by selecting the desired phase

from the pulldown menu next to each phase id found in the image. Click the OK bu�on when

the desired selections have been made.

MicroChar proceeds automatically to perform the following sequence of operations:

1. �e area of each phase is calculated and normalized by the total solid area to yield its area

fraction on a total solids basis.

2. �e mass fraction of each phase, on a total solids basis, is calculated from the area fractions

and knowledge of the density of each phase.

3. �e perimeter of each phase is calculated. For clinker images, the perimeter is de�ned

as the boundary of the given phase with any other phase, including porosity; for cement

images, the perimeter is de�ned as the boundary of the given phase only with interparticle

porosity, because such boundaries determine the reactive surface area with water.

4. False color PNG images are created of (a) the microstructure and (b) the phase perimeters.
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3 APPLICATION TO SRM 2686A

Figure 24: Phase identi�cation is accomplished in MicroChar by accepting the default se�ings

or by selecting the phases from the series of pull down menus.

5. Two-point correlation functions, also known as autocorrelation functions in the �eld of

signal processing, are calculated for each phase (only if the checkbox was activated).

6. �e program halts and prompts you to save your work if you wish, which you may do by

clicking on the disk icon in the tool bar or by typing Ctrl-S.

As it proceeds through this sequence, MicroChar writes a collection of �les to catalog the

results of its calculations. �ese �les, wri�en to the same folder as the original indexed image, all

have the same root name as the indexed image but di�erent �le extensions, as shown in Fig. 25.

Figure 25: Files produced by MicroChar store the results of its calculations.

�ree types of �les are produced for clinker images:

1. a �le ending with ’pfc’
5
, which contain the mass, area, and perimeter fractions of each

phase in the microstructure on a total solids basis, as shown in Fig. 25;

2. �les ending with ’png’ or ’surf.png’, which are the color images of the microstructure and

perimeter, respectively, examples of which are shown in Fig. 26; and

5
�e extension ’pfc’ is an acronym for phase fractions of cement (or clinker).
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3. �les ending with a phase name, which store the two-point correlation function results for

that phase (see example in Fig. 27).

Figure 26: Contents of the pfc �le for the segmented image of SRM 2686a in Fig. 20. Here the

column heading “Volume” corresponds to the phase area fractions and “Area” to the perimeter

fraction.

(a) (b)

Figure 27: (a) False color PNG image of SRM 2686 microstructure, and (b) the phase boundaries.

Field width is 256 µm.

3.5.3 Two-point correlation functions

�e resulting data �les from MicroChar are mostly self-explanatory, as shown in Figs. 26–28.

However, correlation functions may be less familiar to the reader, so they will now be explained

in more detail.

�e two-point correlation function for a phase, S2(r ), is the probability that two randomly

selected points in the image, separated by a distance r , both lie within that phase. In random

composite materials, S2 has some generic features that can be used to characterize the spatial

distribution of the phase. For example, when r = 0, the points coincide; the probability of a

randomly selected point lying within a phase in a 2D image is equal to the area fraction, ϕ, of

that phase, on a total area basis. �erefore, S2(0) = ϕ, that is, the y-intercept of the plot is equal
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3 APPLICATION TO SRM 2686A

(a) (b)

Figure 28: (a) Contents of the alite two-point correlation function data �le for SRM 2686a image

in Fig. 20 with distance in the �rst column and probability density in the second column; (b) plot

of the two-point correlation function S2 for alite and for belite in the SRM 2686a image (right).

to the phase’s area fraction. A second property of S2(r ), which will not be proven here, is that its

limiting slope as r → 0 is directly proportional to the phase’s boundary length per unit area, Σ.

In particular, for granular media the exact relation can be shown to be [3]

lim

r→0
+

dS2

dr
= −

Σ

4

(1)

A third property of S2 is that, at su�ciently large distances between the two points in a

random microstructure, the phase identity of each point should be independent of the other. In

other words, the phase distribution should be uncorrelated at large distances. When two events

are statistically independent, the joint probability is equal to the product of the (unconditional)

individual event probabilities. As stated earlier, the probability of a single point lying within a

phase is the phase’s area fraction, ϕ, so S2 at su�ciently large distances should converge to ϕ2
.

Examination of the plot in Fig. 27 shows that S2(0) = 0.4457 for alite, which therefore is alite’s

area fraction on a total image area basis. Furthermore, the slope at r = 0 for alite is approximately

−0.0158 µm
−1

, which provides a semiquantitative indication of the speci�c boundary area of alite

in the image. Finally, the plot indicates that S2 for neither alite nor belite appears to be converging

to ϕ2
, which is 0.198 for alite and 0.1024 for belite. �is can be interpreted to mean that the

spatial distribution of each phase is still somewhat correlated at distances as large as 200 µm. A

cursory inspection of Fig. 21 suggests that both alite and belite are clustered over a fairly large

length scale, so it is not surprising that the phase distributions are still correlated at 200 µm. �is

hypothesis can be tested by examining a larger segmented image �eld of SRM 2686a, as discussed

in Section 3.6.

Fig. 29 shows the two-point correlation functions for the minority phases arcanite and per-

iclase. �is plot highlights two other features of two-point correlation functions. First, the cor-
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relation functions appear to be converging to values of about 10
−3

for periclase and about 10
−4

for arcanite at distances no greater than about 100 µm. At r = 0, the values of ϕ for periclase

and arcanite are 0.0337 and 0.0046, respectively. Squaring these values gives 0.0011 for periclase

and 0.00002 for arcanite, both values of which are reasonably close to the long-distance values.

�erefore, both periclase and arcanite are concluded to lose any spatial correlation at distances

of about 100 µm.

Figure 29: Two-point correlation functions for periclase and arcanite in SRM 2686a. Note the

two di�erent scales on the y-axes.

�e second feature of the two-point correlation functions in Fig. 29 is the appearance of a

local minimum at short distances followed by a small-amplitude oscillation in the curves. �e

periodic local minima are characteristic of granular media and of non-overlapping domains in

composites, such as periclase and arcanite in SRM 2686a (Fig. 21). In such materials, the distance

at which the �rst local minimum occurs corresponds to about half the average equivalent radius

of the domain, and the distance at which the following local maximum happens corresponds to

the average domain spacing in the microstructure [3]. Inspection of Fig. 29 suggests that the

average equivalent radius of periclase and arcanite domains is about 31 µm and about 18 µm,

respectively. Likewise, the average domain spacings of periclase and arcanite are about 40 µm

and about 27 µm, respectively. Note that these same kinds of features cannot be extracted from

correlation functions when the phases are signi�cantly correlated over long distances, as appears

to be the case for alite and belite in Figs. 27 and 28.
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3.6 Larger Image Field

Image analysis statistics may improve by using larger �elds of view that can capture more of the

intrinsic heterogeneity within the microstructure. For example, Fig. 30 shows a larger image �eld

for SRM 2686a, which was acquired at 200× magni�cation, with a resolution of 1.5 µm/pixel.

(a) (b)

Figure 30: Larger image �eld of SRM 2686a. Magni�cation 300×, 1024×768 pixels. (a) False color

PNG image, and (b) the phase mass, volume, and area fractions. Field width is 1.536 mm.

Notice that the abundances of alite and belite, especially, (Fig. 30(b)) are signi�cantly di�erent

than those measured on the smaller image in earlier sections (Fig. 20). For example, the volume

fraction of alite is 32 % greater, and that of belite 47 % less, than in the smaller image. One would

ordinarily place more con�dence in phase fractions measured on larger �elds of view, which

should reduce errors due to heterogeneity in the microstructure. As already discussed, alite and

belite in the SRM 2686a clinker microstructure are still signi�cantly correlated over the �eld of

view in the smaller image, as shown by the fact that their two-point correlation functions do

not converge to the square of their volume fraction at longer distances (Fig. 28). �erefore, one

should be skeptical that the volume fractions of these phases measured on the smaller image are

representative of the material.

Fig. � shows the two-point correlation functions for alite and belite measured on the larger

�eld of view in Fig. 30(a). In contrast to the corresponding functions for the smaller image, the cor-

relation function for both alite and belite do converge, well within the �eld of view, to the square

of their respective volume fractions. �is result suggests that the larger image in Fig. 30(a) ade-

quately captures all the heterogeneity within the material and, therefore, that phase abundance

estimates based on this image are probably more representative of their true values. In fact, as

shown in Table 3, the clinker phase mass fractions estimated from Fig. 30 are quite close to the
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certi�ed values
6

for this material.

Figure 31: Two-point correlation functions calculated for alite and belite using the large image

�eld of SRM 2686a shown in Fig. 30.

Table 3: Comparison of clinker phase mass fractions, expressed as a percentage of total solids,

estimated for SRM 2686a from the larger �eld of view in Fig. 30 to the certi�ed values [15]. Mea-

surements are based on one image �eld, so no uncertainty estimate is given.

Phase Measured (%) Certi�ed (%) Di�erence (%)

Alite 61.13 63.35 -2.22

Belite 18.59 18.68 -0.09

Aluminate 2.52 2.46 0.06

Ferrite 13.95 10.76 3.19

Periclase 3.55 3.40 0.15

Arcanite 0.27 0.27 0.00

6
Certi�ed values of SRM characteristics, although obviously having some measurement uncertainty, are conven-

tionally treated as “ground truth” for comparison purposes.
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3.7 Multiple Image Statistics for SRM 2686a
When larger image �elds like the one in Fig. 30 are unavailable or are di�cult to capture due to

resolution limits of the microscope, intrinsic heterogeneity can also be accommodated by ana-

lyzing multiple image �elds at higher magni�cation. Running averages and standard deviations

are tracked and checked for consistency with the SRM certi�cate and XRD values for the mass

fraction of each clinker phase.
7

�e results, by imaging �eld, are presented graphically in Fig. 32;

results for each image �eld are also presented in Table 4 along with the certi�ed values and 2-σ
uncertainties (95 % coverage). Consideration must be made that we are working with a medium-

grained, heterogeneous material with this clinker and that heterogeneity will be expressed as

a �eld-to-�eld variability in the measured results. Materials that are heterogeneous at coarser

length scales will have larger �eld-to-�eld variability which, as already shown in the previous

section, can be reduced by using larger imaging areas. However, image �eld enlargement cannot

continue inde�nitely without compromising the resolution and losing grain boundary de�nition.

In fact, multi-phase microstructures will always have �eld-to-�eld variability that generally in-

creases as the image area is reduced. �erefore, uncertainties measured on multiple image �elds

provide an estimate of the heterogeneity length scale relative to the image area: larger uncertain-

ties correspond to greater heterogeneity at the chosen length scale.

Another means of visualizing the results is with the box plot (Fig. 33), where the median

value is used for its resistance to outliers, and is identi�ed by the “X”, the interquartile range (i.e.,
“middle half”) of the data are represented by the body of the box, and the extremes (minimum and

maximum) are represented by the ends of the straight lines projecting out of the box. �e stars

on the plot correspond to the certi�ed values, also tabulated in Table 3. �e constant sum e�ect is

also apparent in Fig. 33 with the values varying inversely with the major phase estimates. �is is

one possible source of bias with normalized estimate methodologies. A cumulative mean estimate

(running average) is presented in Table 4 and in graphical form in Fig. 32. For this clinker and

sampling conditions, the values appear to stabilize a�er four �elds of view and the �nal estimates

are close in value to the certi�ed values.

7
Consistency with a certi�ed value is taken to mean that the mean value of a measured characteristic lies within

one standard deviation of the certi�ed value.
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Table 4: SRM 2686a phase fractions expressed as a mass percent by �eld and a running average.

Mass Percent by Field

Field Alite Belite Aluminate Ferrite Periclase Alkali sulfate

1 66.4 18.8 1.8 9.4 3.1 0.6

2 68.1 16.4 1.9 9.4 3.1 1.0

3 64.1 18.7 2.2 11.0 3.0 1.0

4 64.4 17.6 2.5 11.7 3.0 0.8

5 65.1 17.0 2.4 11.5 3.0 0.8

6 65.3 16.3 2.6 11.9 3.1 0.8

7 64.3 17.0 2.7 12.2 3.0 0.8

8 63.5 18.0 2.8 12.0 3.0 0.7

9 64.3 17.3 2.7 12.0 3.0 0.6

10 64.7 17.5 2.6 11.6 3.0 0.6

11 64.3 17.6 2.6 11.9 3.0 0.6

12 64.8 17.3 2.5 11.7 3.0 0.6

13 64.8 17.0 2.6 11.9 3.0 0.6

14 64.9 17.1 2.5 11.8 3.1 0.7

Mass Percent: Running Average

1 66.4 18.8 1.8 9.4 3.1 0.6

2 67.2 17.6 1.9 9.4 3.1 0.8

3 66.2 18.0 2.0 9.9 3.1 0.8

4 65.8 17.9 2.1 10.4 3.0 0.8

5 65.6 17.7 2.2 10.6 3.0 0.8

6 65.6 17.5 2.2 10.8 3.1 0.8

7 65.4 17.4 2.3 11.0 3.0 0.8

8 65.2 17.5 2.4 11.1 3.0 0.8

9 65.1 17.5 2.4 11.2 3.0 0.8

10 65.0 17.5 2.4 11.3 3.0 0.8

11 65.0 17.5 2.5 11.3 3.0 0.8

12 64.9 17.5 2.5 11.4 3.0 0.7

13 64.9 17.4 2.5 11.4 3.0 0.7

14 64.9 17.4 2.5 11.4 3.0 0.7

2-σ 2.2 1.4 0.6 1.8 0.2 0.2

Certi�cate 63.53 18.80 2.46 10.80 3.40 0.86
2Uc 1.04 1.10 0.39 0.84 0.23 0.17
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Figure 32: Running average plots for SEM/IA analysis of SRM2686a shows values beginning to

stabilize a�er about �ve image �elds.

Appendix A Step-by Step Summary for Clinker Analysis

ImageJ is used to preview the SEM BE and XR images and to interactively make some adjustments

to the background and noise by improving the image quality. We always retain the original images

and use the File→Save As command to save a modi�ed image. Appending the �lename with an

M to indicate the operation performed on the image indicates that it has been modi�ed. By

appending the �lename with an operation code, the images will appear together in the directory,

allowing for easy viewing of the available images. Always save as a TIFF �le format to eliminate

any image quality loss with subsequent processing operations.

1. Read images individually or by drag-and-drop with ImageJ.
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Figure 33: Box plots by phase for SEM analysis of SRM 2686a. Stars indicate certi�ed values.

35



A STEP-BY STEP SUMMARY FOR CLINKER ANALYSIS

2. Tile images to arrange all on the monitor (Window→Tile)

3. Assign a gray LUT to each image (Image→Lookup Table→Grays)

4. Adjust each image’s brightness and contrast to assess the noise associated with low element

concentration or the background (image noise): Image→Adjust→Brightness Contrast

5. Subtract background noise with operation (Process→Subtract) using the preview check box

in the Subtract operation window to interactively select the noise level. When acceptable,

select OK.

6. Clean up any noise by �ltering. �e Despeckle and the Remove Outliers commands un-

der Process→Noise to remove isolated pixels or small pixel groups. �e median �lter (Pro-
cess→Filters→Median) or the �resholded Blur will also work well to reduce image noise

while retaining edge details. Apply any �ltering lightly as edge blur may result in prob-

lems during the segmentation phase. Save the modi�ed image using File→Save As→TIFF,

appending the original �le name with an “M” to indicate this �le has been modi�ed, so that

the original is not over-wri�en.

7. Use MultiSpec to generate a segmented, indexed image where each pixel is uniquely as-

signed to a class to which it most likely belongs based upon a user-developed training set

of data. An abbreviated set of steps, which will be detailed below include (a) reading image

�les, (b) linking �les, (c) designating phase classes, (c) establishing training �elds for each

class, (d) selecting a classi�cation algorithm, (e) evaluating the classi�cation, (f) saving the

project, and (g) saving the classi�ed image as an indexed, segmented TIFF �le. �is image

�le will then be used for the image analysis for determining phase area fraction, phase mass

fraction, and phase perimeter fraction. �e resulting image and phase-related data are use-

ful characteristics of the microstructure and for introduction into simulation models like

VCCTL [4, 21] or THAMES [5].

8. Read initial image as a multispectral type (File→Open Image), and check “multispectral

type” box.

Under “Multispectral Display Speci�cations” accept the defaults with the exception of the

“Enhancement” section, where you can opt to not change the image (the usual), clip it on

the low and high end, or user selected clipping.

9. Link the set of X-ray images deemed useful in making a segmentation: File→Open Image.
Note: �is operation requires selecting “Link to active image window” from the drop-down

box.

Select the X-ray images by clicking on them individually. Remember to select the modi�ed

ones (M). I use a standard image sequence so I can recall the exact image source in the virtual

linked �les (BEI, Al, Mg, K, Na, S) or write it down. �ey can be named later if necessary

and excluded in the classi�cation if desired. Click on the Cancel bu�on to complete the

linking.
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10. Save the image set (Processor→Reformat→Rectify Image)

Use the window defaults (you could a�empt to correct any displaced images here if needed),

make sure the path is correct and provide a name, retaining the .LAN extension. Use the

original �le name to keep them together in a listing. If you do not include the extension,

the �le will be wri�en without one and will not be recognized for future Read operations.

11. Open the .LAN image set for review, assigning classes and training �elds, and classi�cation

(File→Open Image)

You will then see a window labeled “Multispectral Display Speci�cations,” where you can

assign the channels to a color (R G B) and enhance the images by clipping or transforma-

tion. We did the enhancements using ImageJ since Multispec seems to apply a single set of

operations to each image. View the image using di�erent channel/color combinations. �e

most useful are:

• BE, Mg, Al — alite, belite, aluminate, ferrite, periclase, lime, voids

• BE, K, S — alkali sulfates, calcium sulfates

12. Establish training classes (Processor→Statistics)

Accept the defaults in the “Set Project Options” window by clicking OK.

In the new Project window you will see a Class Designation at the top. Enter the list of

classes here by boxing in a region in the image for each, selecting “Add to List” and pro-

viding a name. �e classes are listed based on this sequence and the ultimate index value

used for VCCTL or THAMES, following this convention:

1 = alite 2 = belite 3 = aluminate 4 = ferrite

5 = periclase 6 = arcanite 7 = aphthitalite 8 = void

Record the index designations for later use as some phases will be absent from some mate-

rials.

Subclasses can be created—for example, alkali sulfate could contain sub-classes arcanite

(potassium sulfate) and aphthitalite (potassium, sodium sulfate).

Add training classes then by selecting the class, boxing in more regions, and specifying

“Add to List”. �e more training pixels, the be�er the class characteristics are de�ned.

13. Classify (Processor→Classify)

Specify the “Minimum Euclidian Distance” algorithm as it works consistently well. Check

the box “Write Classi�cation Results” to Disk File and check the path, retaining the .GIS

extension for this image.
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Initial quality check is the percent re-assignment of the training set pixels and the quality

of the class assignment seen in the .GIS image. �e .GIS image is read into Multispec as a

Multispectral type image and you will see the class assignments with distinct colors. �e

colors may be changed by double clinking on the class list followed by se�ing the color

using the color picker.

14. Save the work as a Project

Even if not successful, you can go back and add training �elds, delete �elds, run alternate

classi�cation algorithms, and even exclude speci�c images to see if it can be improved.

15. Save the .GIS �le as a TIFF �le.

�is preserves the color assignments for the phases and the index values. Do not save these

in the .JPG format as the index values and colors will not be saved. You also do not want

to overwrite any �les so append the �le name with a MS su�x.

16. Clean up any mis-assigned pixels using a surface blur �lter that retains edge details.

�e plugin “�resholded Blur” works well for this by ignoring pixels that deviate from the

mean and by allowing you to specify the kernel size (radius, start with 2 or 3), threshold (1

or 2 as this is an indexed image and the values di�er by 1), so�ness (a�ects the edge blur)

and strength (number of times to apply).

17. Read the TIFF �le into ImageJ and write the ASCII Indexed �le (File→Save As→Text Image).

You now have an ASCII �le with the phase index values. If needed, you can recall the .GIS �le

in Multispec or the *MS.TIF �le in ImageJ to see which index value corresponds to each phase.
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